Privilege escalation in the Sulu Admin panel
CVE-2021-43835GHSA-84px-q68r-2fc9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sulu/sulu 2.4.0, 2.3.8, 2.2.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sulu/sulu
- Affected
- >= 2.0.0, <= 2.2.17>= 2.3.0, <= 2.3.7>= 2.4.0-RC1, <= 2.4.0-RC1
- Fixed in
- 2.4.0, 2.2.18, 2.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-84px-q68r-2fc9 lists affected ranges: Packagist sulu/sulu >=2.0.0 =2.3.0 =2.4.0-RC1 <=2.4.0-RC1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-43835: 1.17% estimated exploitation activity in the next 30 days; percentile 67.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Impacted are only users which already have access to the admin UI. Over the API it was possible for them to give themselves permissions to areas which they did not already had. This issue was introduced in 2.0.0-RC1 with the new ProfileController putAction. Patches The versions have been patched in 2.2.18, 2.3.8 and 2.4.0. Workarounds Patching the ProfileController of affected sulu versions yourself by overwriting it. References Are there any links users can visit to find out more? Currently not. For more information If you have any questions or comments about this advisory: Open an issue in sulu/sulu repo Email us at security@sulu.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-84px-q68r-2fc9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43835 Advisory: Privilege escalation in the Sulu Admin panel IDs: CVE-2021-43835, GHSA-84px-q68r-2fc9 Record: https://patchnext.com/advisories/cve-2021-43835 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sulu/sulu 2.4.0, 2.3.8, 2.2.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sulu/sulu: affected >= 2.0.0, <= 2.2.17; >= 2.3.0, <= 2.3.7; >= 2.4.0-RC1, <= 2.4.0-RC1; fixed in 2.4.0, 2.2.18, 2.3.8 ## Suggested inspection (read-only) - Packagist sulu/sulu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sulu/sulu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-84px-q68r-2fc9 (GitHub-reviewed advisory GHSA-84px-q68r-2fc9 lists affected ranges: Packagist sulu/sulu >=2.0.0 =2.3.0 =2.4.0-RC1 <=2.4.0-RC1) Commands are suggestions: review each one before running it.
Loading voting…