SQL injection in jackalope/jackalope-doctrine-dbal
CVE-2021-43822GHSA-ph98-v78f-jqrm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jackalope/jackalope-doctrine-dbal 1.7.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist jackalope/jackalope-doctrine-dbal
- Affected
- < 1.7.4
- Fixed in
- 1.7.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ph98-v78f-jqrm lists affected ranges: Packagist jackalope/jackalope-doctrine-dbal >=0 <1.7.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-43822: 1.00% estimated exploitation activity in the next 30 days; percentile 62.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users can provoke SQL injections if they can specify a node name or query. Patches Upgrade to version 1.7.4 If that is not possible, you can escape all places where $property is used to filter sv:name in the class Jackalope\Transport\DoctrineDBAL\Query\QOMWalker: XPath::escape($property). Workarounds Node names and xpaths can contain " or ; according to the JCR specification. The jackalope component that translates the query object model into doctrine dbal queries does not properly escape the names and paths, so that a accordingly crafted node name can lead to an SQL injection. If queries are never done from user input, or if you validate the user input to not contain ;, you are not affected. References No further references. For more information If you have any questions or comments about this advisory: Open an issue in jackalope/jackalope-doctrine-dbal repo
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ph98-v78f-jqrm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43822 Advisory: SQL injection in jackalope/jackalope-doctrine-dbal IDs: CVE-2021-43822, GHSA-ph98-v78f-jqrm Record: https://patchnext.com/advisories/cve-2021-43822 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jackalope/jackalope-doctrine-dbal 1.7.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist jackalope/jackalope-doctrine-dbal: affected < 1.7.4; fixed in 1.7.4 ## Suggested inspection (read-only) - Packagist jackalope/jackalope-doctrine-dbal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jackalope/jackalope-doctrine-dbal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ph98-v78f-jqrm (GitHub-reviewed advisory GHSA-ph98-v78f-jqrm lists affected ranges: Packagist jackalope/jackalope-doctrine-dbal >=0 <1.7.4) Commands are suggestions: review each one before running it.
Loading voting…