lxml's HTML Cleaner allows crafted and SVG embedded scripts to pass through
CVE-2021-43818GHSA-55x5-fj6c-h6m8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lxml 4.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lxml
- Affected
- < 4.6.5
- Fixed in
- 4.6.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-55x5-fj6c-h6m8 lists affected ranges: PyPI lxml >=0 <4.6.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-55x5-fj6c-h6m8 lists affected ranges: PyPI lxml >=0 <4.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N · score source
- EPSS
- CVE-2021-43818: 2.66% estimated exploitation activity in the next 30 days; percentile 85.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The HTML Cleaner in lxml.html lets certain crafted script content pass through, as well as script content in SVG files embedded using data URIs. Users that employ the HTML cleaner in a security relevant context should upgrade to lxml 4.6.5. Patches The issue has been resolved in lxml 4.6.5. Workarounds None. References The issues are tracked under the report IDs GHSL-2021-1037 and GHSL-2021-1038.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-55x5-fj6c-h6m8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-55x5-fj6c-h6m8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43818 Advisory: lxml's HTML Cleaner allows crafted and SVG embedded scripts to pass through IDs: CVE-2021-43818, GHSA-55x5-fj6c-h6m8 Record: https://patchnext.com/advisories/cve-2021-43818 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lxml 4.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lxml: affected < 4.6.5; fixed in 4.6.5 ## Suggested inspection (read-only) - `python -m pip show lxml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lxml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-55x5-fj6c-h6m8 (OSV record GHSA-55x5-fj6c-h6m8 lists affected ranges: PyPI lxml >=0 <4.6.5 (fixed)) - Verified: https://github.com/advisories/GHSA-55x5-fj6c-h6m8 (GitHub-reviewed advisory GHSA-55x5-fj6c-h6m8 lists affected ranges: PyPI lxml >=0 <4.6.5) Commands are suggestions: review each one before running it.
Loading voting…