Skip to content

← Actionable
High, CVSS 8.0

Unprivileged pod using hostPath can side-step active LSM when it is SELinux

CVE-2021-43816GHSA-mvff-h3cj-wj9c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2021-43816: 1.81% estimated exploitation activity in the next 30 days; percentile 78.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Containers launched through containerd’s CRI implementation on Linux systems which use the SELinux security module and containerd versions since v1.5.0 can cause arbitrary files and directories on the host to be relabeled to match the container process label through the use of specially-configured bind mounts in a hostPath volume. This relabeling elevates permissions for the container, granting full read/write access over the affected files and directories. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. If you are not using containerd’s CRI implementation (through one of the mechanisms described above), you are not affected by this issue. Patches This bug has been fixed in containerd 1.5.9. Because file labels persist independently of containerd, users should both update to these versions as soon as they are released and validate that all files on their host are correctly labeled. Workarounds Ensure that no sensitive files or directories…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mvff-h3cj-wj9c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-43816

Advisory: Unprivileged pod using `hostPath` can side-step active LSM when it is SELinux
IDs: CVE-2021-43816, GHSA-mvff-h3cj-wj9c
Record: https://patchnext.com/advisories/cve-2021-43816 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd: affected >= 1.5.0, < 1.5.9; fixed in 1.5.9

## Suggested inspection (read-only)
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mvff-h3cj-wj9c (GitHub-reviewed advisory GHSA-mvff-h3cj-wj9c lists affected ranges: Go github.com/containerd/containerd >=1.5.0 <1.5.9)

Commands are suggestions: review each one before running it.

Loading voting…