Open redirect in @auth0/nextjs-auth0
CVE-2021-43812GHSA-2mqv-4j3r-vjvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@auth0/nextjs-auth0 1.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.6.2
- Fixed in
- 1.6.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2mqv-4j3r-vjvp lists affected ranges: npm @auth0/nextjs-auth0 >=0 <1.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mqv-4j3r-vjvp lists affected ranges: npm @auth0/nextjs-auth0 >=0 <1.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-43812: 0.68% estimated exploitation activity in the next 30 days; percentile 52.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview Versions <=1.6.1 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability. Am I affected? You are affected by this vulnerability if you are using @auth0/nextjs-auth0 version <=1.6.1. How to fix that? Upgrade to version =1.6.2 Will this update impact my users? The fix provided in the patch will not affect your users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2mqv-4j3r-vjvp
- Revision 1 · created ·
Published from osv record GHSA-2mqv-4j3r-vjvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43812 Advisory: Open redirect in @auth0/nextjs-auth0 IDs: CVE-2021-43812, GHSA-2mqv-4j3r-vjvp Record: https://patchnext.com/advisories/cve-2021-43812 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @auth0/nextjs-auth0 1.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @auth0/nextjs-auth0: affected < 1.6.2; fixed in 1.6.2 ## Suggested inspection (read-only) - `npm ls @auth0/nextjs-auth0 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @auth0/nextjs-auth0. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2mqv-4j3r-vjvp (OSV record GHSA-2mqv-4j3r-vjvp lists affected ranges: npm @auth0/nextjs-auth0 >=0 <1.6.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2mqv-4j3r-vjvp (GitHub-reviewed advisory GHSA-2mqv-4j3r-vjvp lists affected ranges: npm @auth0/nextjs-auth0 >=0 <1.6.2) Commands are suggestions: review each one before running it.
Loading voting…