Skip to content

← Actionable
High, CVSS 7.5amended

Unexpected server crash in Next.js.

CVE-2021-43803GHSA-25mp-g6fv-mqxx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 12.0.5, 11.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 12.0.0, < 12.0.5>= 0.9.9, < 11.1.3
    Fixed in
    11.1.3, 12.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-43803: 47.25% estimated exploitation activity in the next 30 days; percentile 98.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue. Note that prior version 0.9.9 package next hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-25mp-g6fv-mqxx

  2. Revision 1 · created ·

    Published from osv record GHSA-25mp-g6fv-mqxx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-43803

Advisory: Unexpected server crash in Next.js.
IDs: CVE-2021-43803, GHSA-25mp-g6fv-mqxx
Record: https://patchnext.com/advisories/cve-2021-43803 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 12.0.5, 11.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 12.0.0, < 12.0.5; >= 0.9.9, < 11.1.3; fixed in 11.1.3, 12.0.5

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-25mp-g6fv-mqxx (OSV record GHSA-25mp-g6fv-mqxx lists affected ranges: npm next >=12.0.0 =0.9.9 <11.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-25mp-g6fv-mqxx (GitHub-reviewed advisory GHSA-25mp-g6fv-mqxx lists affected ranges: npm next >=12.0.0 =0.9.9 <11.1.3)

Commands are suggestions: review each one before running it.

Loading voting…