Path Traversal in com.linecorp.armeria:armeria
CVE-2021-43795GHSA-8fp4-rp6c-5gcv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.linecorp.armeria:armeria 1.13.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.linecorp.armeria:armeria
- Affected
- >= 1.12.0, < 1.13.4
- Fixed in
- 1.13.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8fp4-rp6c-5gcv lists affected ranges: Maven com.linecorp.armeria:armeria >=1.12.0 <1.13.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-43795: 1.69% estimated exploitation activity in the next 30 days; percentile 77.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can access an Armeria server's local file system beyond its restricted directory by sending an HTTP request whose path contains %2F (encoded /), such as /files/..%2Fsecrets.txt, bypassing Armeria's path validation logic. Patches Armeria 1.13.4 or above contains the hardened path validation logic that handles %2F properly. Workarounds This vulnerability can be worked around by inserting a decorator that performs an additional validation on the request path, e.g. For more information If you have any questions or comments about this advisory: Open an issue in line/armeria Chat with us at Slack Credits This vulnerability was originally reported by Abdallah Zaher (elcayser-0x0a).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8fp4-rp6c-5gcv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43795 Advisory: Path Traversal in com.linecorp.armeria:armeria IDs: CVE-2021-43795, GHSA-8fp4-rp6c-5gcv Record: https://patchnext.com/advisories/cve-2021-43795 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.linecorp.armeria:armeria 1.13.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.linecorp.armeria:armeria: affected >= 1.12.0, < 1.13.4; fixed in 1.13.4 ## Suggested inspection (read-only) - Maven com.linecorp.armeria:armeria: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.linecorp.armeria:armeria. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8fp4-rp6c-5gcv (GitHub-reviewed advisory GHSA-8fp4-rp6c-5gcv lists affected ranges: Maven com.linecorp.armeria:armeria >=1.12.0 <1.13.4) Commands are suggestions: review each one before running it.
Loading voting…