Overflow in netlink bytemsg length field allows attacker to override netlink-based container configuration in RunC
CVE-2021-43784GHSA-v95c-p5hm-xq8f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/opencontainers/runc 1.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/opencontainers/runc
- Affected
- < 1.0.3
- Fixed in
- 1.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v95c-p5hm-xq8f lists affected ranges: Go github.com/opencontainers/runc >=0 <1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L
- EPSS
- CVE-2021-43784: 1.80% estimated exploitation activity in the next 30 days; percentile 78.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In runc, netlink is used internally as a serialization system for specifying the relevant container configuration to the C portion of our code (responsible for the based namespace setup of containers). In all versions of runc prior to 1.0.3, the encoder did not handle the possibility of an integer overflow in the 16-bit length field for the byte array attribute type, meaning that a large enough malicious byte array attribute could result in the length overflowing and the attribute contents being parsed as netlink messages for container configuration. This vulnerability requires the attacker to have some control over the configuration of the container and would allow the attacker to bypass the namespace restrictions of the container by simply adding their own netlink payload which disables all namespaces. Prior to 9c444070ec7bb83995dbc0185da68284da71c554, in practice it was fairly difficult to specify an arbitrary-length netlink message with most container runtimes. The only…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v95c-p5hm-xq8f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43784 Advisory: Overflow in netlink bytemsg length field allows attacker to override netlink-based container configuration in RunC IDs: CVE-2021-43784, GHSA-v95c-p5hm-xq8f Record: https://patchnext.com/advisories/cve-2021-43784 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/opencontainers/runc 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/opencontainers/runc: affected < 1.0.3; fixed in 1.0.3 ## Suggested inspection (read-only) - Go github.com/opencontainers/runc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/opencontainers/runc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v95c-p5hm-xq8f (GitHub-reviewed advisory GHSA-v95c-p5hm-xq8f lists affected ranges: Go github.com/opencontainers/runc >=0 <1.0.3) Commands are suggestions: review each one before running it.
Loading voting…