Skip to content

← Actionable
High, CVSS 7.4amended

Cross-Site Scripting vulnerability in @backstage/plugin-auth-backend

CVE-2021-43776GHSA-w7fj-336r-vw49

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-auth-backend 0.4.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2021-43776: 0.68% estimated exploitation activity in the next 30 days; percentile 52.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user's browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities. Patches This is vulnerability is patched in version 0.4.9 of @backstage/plugin-auth-backend. For more information If you have any questions or comments about this advisory: Open an issue in the Backstage repository Visit our chat, linked to in Backstage README

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w7fj-336r-vw49

  2. Revision 1 · created ·

    Published from osv record GHSA-w7fj-336r-vw49

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-43776

Advisory: Cross-Site Scripting vulnerability in @backstage/plugin-auth-backend
IDs: CVE-2021-43776, GHSA-w7fj-336r-vw49
Record: https://patchnext.com/advisories/cve-2021-43776 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-auth-backend 0.4.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-auth-backend: affected < 0.4.9; fixed in 0.4.9

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-auth-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-auth-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w7fj-336r-vw49 (OSV record GHSA-w7fj-336r-vw49 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.4.9 (fixed))
- Verified: https://github.com/advisories/GHSA-w7fj-336r-vw49 (GitHub-reviewed advisory GHSA-w7fj-336r-vw49 lists affected ranges: npm @backstage/plugin-auth-backend >=0 <0.4.9)

Commands are suggestions: review each one before running it.

Loading voting…