Arbitrary file reading vulnerability in Aim
CVE-2021-43775GHSA-8phj-f9w2-cjcc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aim 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI aim
- Affected
- < 3.1.0
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8phj-f9w2-cjcc lists affected ranges: PyPI aim >=0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8phj-f9w2-cjcc lists affected ranges: PyPI aim >=0 <3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2021-43775: 1.91% estimated exploitation activity in the next 30 days; percentile 79.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A path traversal attack aims to access files and directories that are stored outside the web root folder. By manipulating variables that reference files with “dot-dot-slash (../)” sequences and its variations or by using absolute file paths, it may be possible to access arbitrary files and directories stored on file system including application source code or configuration and critical system files. Vulnerable code: https://github.com/aimhubio/aim/blob/0b99c6ca08e0ba7e7011453a2f68033e9b1d1bce/aim/web/api/views.py#L9-L16 Patches The vulnerability issue is resolved in Aim v3.1.0. References https://owasp.org/www-community/attacks/PathTraversal
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8phj-f9w2-cjcc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8phj-f9w2-cjcc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43775 Advisory: Arbitrary file reading vulnerability in Aim IDs: CVE-2021-43775, GHSA-8phj-f9w2-cjcc Record: https://patchnext.com/advisories/cve-2021-43775 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aim 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI aim: affected < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - `python -m pip show aim`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8phj-f9w2-cjcc (OSV record GHSA-8phj-f9w2-cjcc lists affected ranges: PyPI aim >=0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8phj-f9w2-cjcc (GitHub-reviewed advisory GHSA-8phj-f9w2-cjcc lists affected ranges: PyPI aim >=0 <3.1.0) Commands are suggestions: review each one before running it.
Loading voting…