Improper Verification of Cryptographic Signature in starkbank-ecdsa
CVE-2021-43569GHSA-j3jw-j2j8-2wv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (starkbank-ecdsa 1.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet starkbank-ecdsa
- Affected
- < 1.3.2
- Fixed in
- 1.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3jw-j2j8-2wv9 lists affected ranges: NuGet starkbank-ecdsa >=0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-43569: 1.06% estimated exploitation activity in the next 30 days; percentile 64.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The verify function in the Stark Bank .NET ECDSA library (ecdsa-dotnet) 1.3.1 fails to check that the signature is non-zero, which allows attackers to forge signatures on arbitrary messages.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3jw-j2j8-2wv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43569 Advisory: Improper Verification of Cryptographic Signature in starkbank-ecdsa IDs: CVE-2021-43569, GHSA-j3jw-j2j8-2wv9 Record: https://patchnext.com/advisories/cve-2021-43569 (revision 1, source checked 26 Oct 2026, 16:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: starkbank-ecdsa 1.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet starkbank-ecdsa: affected < 1.3.2; fixed in 1.3.2 ## Suggested inspection (read-only) - NuGet starkbank-ecdsa: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on starkbank-ecdsa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3jw-j2j8-2wv9 (GitHub-reviewed advisory GHSA-j3jw-j2j8-2wv9 lists affected ranges: NuGet starkbank-ecdsa >=0 <1.3.2) Commands are suggestions: review each one before running it.
Loading voting…