Cross-site Scripting in moodle
CVE-2021-43558GHSA-wpfp-q843-v772
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.11.4, 3.10.8, 3.9.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.11.0, < 3.11.4>= 3.10.0, < 3.10.8>= 3.9.0, < 3.9.11
- Fixed in
- 3.10.8, 3.9.11, 3.11.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wpfp-q843-v772 lists affected ranges: Packagist moodle/moodle >=3.11.0 =3.10.0 =3.9.0 <3.9.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-43558: 0.87% estimated exploitation activity in the next 30 days; percentile 58.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wpfp-q843-v772
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43558 Advisory: Cross-site Scripting in moodle IDs: CVE-2021-43558, GHSA-wpfp-q843-v772 Record: https://patchnext.com/advisories/cve-2021-43558 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.11.4, 3.10.8, 3.9.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.11.0, < 3.11.4; >= 3.10.0, < 3.10.8; >= 3.9.0, < 3.9.11; fixed in 3.10.8, 3.9.11, 3.11.4 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wpfp-q843-v772 (GitHub-reviewed advisory GHSA-wpfp-q843-v772 lists affected ranges: Packagist moodle/moodle >=3.11.0 =3.10.0 =3.9.0 <3.9.11) Commands are suggestions: review each one before running it.
Loading voting…