uri-template-lite Regular Expression Denial of Service
CVE-2021-43309GHSA-chw2-6c7r-37p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uri-template-lite 22.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 22.9.0
- Fixed in
- 22.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-chw2-6c7r-37p7 lists affected ranges: npm uri-template-lite >=0 <22.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-chw2-6c7r-37p7 lists affected ranges: npm uri-template-lite >=0 <22.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-43309: 0.99% estimated exploitation activity in the next 30 days; percentile 62.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the uri-template-lite npm package, when an attacker is able to supply arbitrary input to the "URI.expand" method.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-chw2-6c7r-37p7
- Revision 1 · created ·
Published from osv record GHSA-chw2-6c7r-37p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43309 Advisory: uri-template-lite Regular Expression Denial of Service IDs: CVE-2021-43309, GHSA-chw2-6c7r-37p7 Record: https://patchnext.com/advisories/cve-2021-43309 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uri-template-lite 22.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm uri-template-lite: affected < 22.9.0; fixed in 22.9.0 ## Suggested inspection (read-only) - `npm ls uri-template-lite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uri-template-lite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-chw2-6c7r-37p7 (OSV record GHSA-chw2-6c7r-37p7 lists affected ranges: npm uri-template-lite >=0 <22.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-chw2-6c7r-37p7 (GitHub-reviewed advisory GHSA-chw2-6c7r-37p7 lists affected ranges: npm uri-template-lite >=0 <22.9.0) Commands are suggestions: review each one before running it.
Loading voting…