Regular expression denial of service in jquery-validation
CVE-2021-43306GHSA-j9m2-h2pv-wvph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery-validation 1.19.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.19.4
- Fixed in
- 1.19.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j9m2-h2pv-wvph lists affected ranges: npm jquery-validation >=0 <1.19.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j9m2-h2pv-wvph lists affected ranges: npm jquery-validation >=0 <1.19.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-43306: 1.52% estimated exploitation activity in the next 30 days; percentile 74.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the jquery-validation npm package, when an attacker is able to supply arbitrary input to the url2 method
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j9m2-h2pv-wvph
- Revision 1 · created ·
Published from osv record GHSA-j9m2-h2pv-wvph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43306 Advisory: Regular expression denial of service in jquery-validation IDs: CVE-2021-43306, GHSA-j9m2-h2pv-wvph Record: https://patchnext.com/advisories/cve-2021-43306 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jquery-validation 1.19.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jquery-validation: affected < 1.19.4; fixed in 1.19.4 ## Suggested inspection (read-only) - `npm ls jquery-validation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jquery-validation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j9m2-h2pv-wvph (OSV record GHSA-j9m2-h2pv-wvph lists affected ranges: npm jquery-validation >=0 <1.19.4 (fixed)) - Verified: https://github.com/advisories/GHSA-j9m2-h2pv-wvph (GitHub-reviewed advisory GHSA-j9m2-h2pv-wvph lists affected ranges: npm jquery-validation >=0 <1.19.4) Commands are suggestions: review each one before running it.
Loading voting…