WebPA SQL Injection vulnerability
CVE-2021-4308GHSA-mjgw-f2c4-f8qj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpa/webpa 3.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist webpa/webpa
- Affected
- < 3.1.2
- Fixed in
- 3.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mjgw-f2c4-f8qj lists affected ranges: Packagist webpa/webpa >=0 <3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-4308: 0.71% estimated exploitation activity in the next 30 days; percentile 53.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in WebPA up to 3.1.1. It has been rated as critical. This issue affects some unknown processing. The manipulation leads to sql injection. Upgrading to version 3.1.2 can to address this issue. The name of the patch is 8836c4f549181e885a68e0e7ca561fdbcbd04bf0. It is recommended to upgrade the affected component. The identifier VDB-217637 was assigned to this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mjgw-f2c4-f8qj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4308 Advisory: WebPA SQL Injection vulnerability IDs: CVE-2021-4308, GHSA-mjgw-f2c4-f8qj Record: https://patchnext.com/advisories/cve-2021-4308 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: webpa/webpa 3.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist webpa/webpa: affected < 3.1.2; fixed in 3.1.2 ## Suggested inspection (read-only) - Packagist webpa/webpa: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on webpa/webpa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mjgw-f2c4-f8qj (GitHub-reviewed advisory GHSA-mjgw-f2c4-f8qj lists affected ranges: Packagist webpa/webpa >=0 <3.1.2) Commands are suggestions: review each one before running it.
Loading voting…