Baobab vulnerable to Prototype Pollution
CVE-2021-4307GHSA-wvr2-q86m-6whp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (baobab 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm baobab
- Affected
- < 2.6.1
- Fixed in
- 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvr2-q86m-6whp lists affected ranges: npm baobab >=0 <2.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvr2-q86m-6whp lists affected ranges: npm baobab >=0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-4307: 1.31% estimated exploitation activity in the next 30 days; percentile 70.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in Yomguithereal Baobab up to 2.6.0. It has been declared as critical. Affected by this vulnerability is an unknown functionality. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). The attack can be launched remotely. Upgrading to version 2.6.1 is able to address this issue. The name of the patch is c56639532a923d9a1600fb863ec7551b188b5d19. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217627.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wvr2-q86m-6whp
- Revision 1 · created ·
Published from osv record GHSA-wvr2-q86m-6whp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4307 Advisory: Baobab vulnerable to Prototype Pollution IDs: CVE-2021-4307, GHSA-wvr2-q86m-6whp Record: https://patchnext.com/advisories/cve-2021-4307 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: baobab 2.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm baobab: affected < 2.6.1; fixed in 2.6.1 ## Suggested inspection (read-only) - `npm ls baobab --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on baobab. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvr2-q86m-6whp (OSV record GHSA-wvr2-q86m-6whp lists affected ranges: npm baobab >=0 <2.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-wvr2-q86m-6whp (GitHub-reviewed advisory GHSA-wvr2-q86m-6whp lists affected ranges: npm baobab >=0 <2.6.1) Commands are suggestions: review each one before running it.
Loading voting…