Skip to content

← Actionable
Medium, CVSS 6.1

Xataface vulnerable to Cross-site Scripting

CVE-2021-4303GHSA-64wv-c7jw-jw2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xataface/xataface 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-4303: 0.53% estimated exploitation activity in the next 30 days; percentile 45.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability, which was classified as problematic, has been found in shannah Xataface up to 2.x. Affected by this issue is the function testftp of the file install/installform.js.php of the component Installer. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 3.0.0 can address this issue. The name of the patch is 94143a4299e386f33bf582139cd4702571d93bde. It is recommended to upgrade the affected component. VDB-217442 is the identifier assigned to this vulnerability. NOTE: Installer is disabled by default.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-64wv-c7jw-jw2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-4303

Advisory: Xataface vulnerable to Cross-site Scripting
IDs: CVE-2021-4303, GHSA-64wv-c7jw-jw2q
Record: https://patchnext.com/advisories/cve-2021-4303 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xataface/xataface 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist xataface/xataface: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- Packagist xataface/xataface: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xataface/xataface.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-64wv-c7jw-jw2q (GitHub-reviewed advisory GHSA-64wv-c7jw-jw2q lists affected ranges: Packagist xataface/xataface >=0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…