Neo4j Graph Database vulnerable to Path Traversal
CVE-2021-42767GHSA-4mpj-488r-vh6m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.neo4j.procedure:apoc 4.4.0.1, 4.3.0.4, 4.2.10, 3.5.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.neo4j.procedure:apoc
- Affected
- < 3.5.17>= 4.2.0, < 4.2.10>= 4.3.0.0, <= 4.3.0.3>= 4.4.0.0, <= 4.4.0.0
- Fixed in
- 4.4.0.1, 4.2.10, 3.5.17, 4.3.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mpj-488r-vh6m lists affected ranges: Maven org.neo4j.procedure:apoc >=0 =4.2.0 =4.3.0.0 =4.4.0.0 <=4.4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-42767: 1.53% estimated exploitation activity in the next 30 days; percentile 74.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Directory Traversal Vulnerabilities found in several functions of apoc plugins in Neo4j Graph database. The attacker can retrieve and download files from outside the configured directory on the affected server. Under some circumstances, the attacker can also create files. Patches The users should aim to use the latest released version compatible with their Neo4j version. The minimum versions containing patch for this vulnerability (for Neo4j 4.2, 4.3, and 4.4 bundled with APOC, upgrade to the appropriate patched version): 3.5 - bundle n/a, standalone 3.5.0.17 4.2 - bundle 4.2.13, standalone 4.2.0.10 4.3 - bundle 4.3.9, standalone 4.3.0.4 4.4 - bundle 4.4.2, standalone 4.4.0.1 Workarounds If you cannot upgrade the library, you can control the allowlist of the functions that can be used in your system: For more information If you have any questions or comments about this advisory: Open an issue in neo4j-apoc-procedures Email us at security@neo4j.com Credits We want to publicly…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4mpj-488r-vh6m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-42767 Advisory: Neo4j Graph Database vulnerable to Path Traversal IDs: CVE-2021-42767, GHSA-4mpj-488r-vh6m Record: https://patchnext.com/advisories/cve-2021-42767 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.neo4j.procedure:apoc 4.4.0.1, 4.3.0.4, 4.2.10, 3.5.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.neo4j.procedure:apoc: affected < 3.5.17; >= 4.2.0, < 4.2.10; >= 4.3.0.0, <= 4.3.0.3; >= 4.4.0.0, <= 4.4.0.0; fixed in 4.4.0.1, 4.2.10, 3.5.17, 4.3.0.4 ## Suggested inspection (read-only) - Maven org.neo4j.procedure:apoc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.neo4j.procedure:apoc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mpj-488r-vh6m (GitHub-reviewed advisory GHSA-4mpj-488r-vh6m lists affected ranges: Maven org.neo4j.procedure:apoc >=0 =4.2.0 =4.3.0.0 =4.4.0.0 <=4.4.0.0) Commands are suggestions: review each one before running it.
Loading voting…