Improper Neutralization of Special Elements used in a Command in Shell-quote
CVE-2021-42740GHSA-g4rg-993r-mgx7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shell-quote 1.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm shell-quote
- Affected
- >= 1.6.3, <= 1.7.2
- Fixed in
- 1.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g4rg-993r-mgx7 lists affected ranges: npm shell-quote >=1.6.3 <1.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4rg-993r-mgx7 lists affected ranges: npm shell-quote >=1.6.3 <=1.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-42740: 4.22% estimated exploitation activity in the next 30 days; percentile 91.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The shell-quote package before 1.7.3 for Node.js allows command injection. An attacker can inject unescaped shell metacharacters through a regex designed to support Windows drive letters. If the output of this package is passed to a real shell as a quoted argument to a command with exec(), an attacker can inject arbitrary commands. This is because the Windows drive letter regex character class is [A-z] instead of the correct [A-Za-z]. Several shell metacharacters exist in the space between capital letter Z and lower case letter a, such as the backtick character.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g4rg-993r-mgx7
- Revision 1 · created ·
Published from osv record GHSA-g4rg-993r-mgx7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-42740 Advisory: Improper Neutralization of Special Elements used in a Command in Shell-quote IDs: CVE-2021-42740, GHSA-g4rg-993r-mgx7 Record: https://patchnext.com/advisories/cve-2021-42740 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shell-quote 1.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm shell-quote: affected >= 1.6.3, <= 1.7.2; fixed in 1.7.3 ## Suggested inspection (read-only) - `npm ls shell-quote --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shell-quote. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g4rg-993r-mgx7 (OSV record GHSA-g4rg-993r-mgx7 lists affected ranges: npm shell-quote >=1.6.3 <1.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-g4rg-993r-mgx7 (GitHub-reviewed advisory GHSA-g4rg-993r-mgx7 lists affected ranges: npm shell-quote >=1.6.3 <=1.7.2) Commands are suggestions: review each one before running it.
Loading voting…