Websocket requests did not call AuthenticateMethod
CVE-2021-4236GHSA-5gjg-jgh4-gppm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ecnepsnai/web 1.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.4.0, < 1.5.2
- Fixed in
- 1.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5gjg-jgh4-gppm lists affected ranges: Go github.com/ecnepsnai/web >=1.4.0 <1.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-4236: 1.19% estimated exploitation activity in the next 30 days; percentile 68.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Depending on implementation, a denial-of-service or privilege escalation vulnerability may occur in software that uses the github.com/ecnepsnai/web package with Web Sockets that have an AuthenticateMethod. The AuthenticateMethod is not called, and UserData will be nil in request methods. Attempts to read the UserData may result in a panic. This issue only affects web sockets where an AuthenticateMethod is supplied to the handle options. Users who do not use web sockets, or users who do not require authentication are not at risk. Example In the example below, one would expect that the AuthenticateMethod function would be called for each request to /example However, the method is not called, and therefor the UserData parameter of the request object in the handle will be nil, when it would have been expected to be the session object we returned. Patches Release v1.5.2 fixes this vulnerability. The authenticate method is now called for websocket requests. All users of the web…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5gjg-jgh4-gppm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4236 Advisory: Websocket requests did not call AuthenticateMethod IDs: CVE-2021-4236, GHSA-5gjg-jgh4-gppm Record: https://patchnext.com/advisories/cve-2021-4236 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/ecnepsnai/web 1.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/ecnepsnai/web: affected >= 1.4.0, < 1.5.2; fixed in 1.5.2 ## Suggested inspection (read-only) - Go github.com/ecnepsnai/web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/ecnepsnai/web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5gjg-jgh4-gppm (GitHub-reviewed advisory GHSA-5gjg-jgh4-gppm lists affected ranges: Go github.com/ecnepsnai/web >=1.4.0 <1.5.2) Commands are suggestions: review each one before running it.
Loading voting…