Skip to content

← Actionable
Medium, CVSS 5.5

YAML Go package vulnerable to denial of service

CVE-2021-4235GHSA-r88r-gmrh-7j83

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go gopkg.in/yaml.v2

    Affected
    < 2.2.3
    Fixed in
    2.2.3
  • Go github.com/go-yaml/yaml

    Affected
    <= 2.1.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-4235: 0.43% estimated exploitation activity in the next 30 days; percentile 37.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Due to unbounded alias chasing, a maliciously crafted YAML file can cause the system to consume significant system resources. If parsing user input, this may be used as a denial of service vector.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r88r-gmrh-7j83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-4235

Advisory: YAML Go package vulnerable to denial of service
IDs: CVE-2021-4235, GHSA-r88r-gmrh-7j83
Record: https://patchnext.com/advisories/cve-2021-4235 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: gopkg.in/yaml.v2 2.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gopkg.in/yaml.v2: affected < 2.2.3; fixed in 2.2.3
- Go github.com/go-yaml/yaml: affected <= 2.1.0

## Suggested inspection (read-only)
- Go gopkg.in/yaml.v2: check the installed version with your package manager.
- Go github.com/go-yaml/yaml: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gopkg.in/yaml.v2, github.com/go-yaml/yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r88r-gmrh-7j83 (GitHub-reviewed advisory GHSA-r88r-gmrh-7j83 lists affected ranges: Go gopkg.in/yaml.v2 >=0 =0 <=2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…