Skip to content

← Actionable
Critical, CVSS 9.3amended

PYSEC-2021-387

CVE-2021-42343GHSA-hwqr-f3v9-hwxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dask 2021.10.0; distributed 2021.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dask

    Affected
    < 2021.10.0
    Fixed in
    2021.10.0
  • PyPI distributed

    Affected
    < 2021.10.0
    Fixed in
    2021.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-42343: 2.98% estimated exploitation activity in the next 30 days; percentile 87.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Dask (aka python-dask) through 2021.09.1. Single machine Dask clusters started with dask.distributed.LocalCluster or dask.distributed.Client (which defaults to using LocalCluster) would mistakenly configure their respective Dask workers to listen on external interfaces (typically with a randomly selected high port) rather than only on localhost. A Dask cluster created using this method (when running on a machine that has an applicable port exposed) could be used by a sophisticated attacker to achieve remote code execution.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2021-387

  3. Revision 1 · created ·

    Published from osv record GHSA-hwqr-f3v9-hwxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-42343

Advisory: PYSEC-2021-387
IDs: CVE-2021-42343, GHSA-hwqr-f3v9-hwxr
Record: https://patchnext.com/advisories/cve-2021-42343 (revision 3, source checked 25 Oct 2026, 02:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dask 2021.10.0; distributed 2021.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dask: affected < 2021.10.0; fixed in 2021.10.0
- PyPI distributed: affected < 2021.10.0; fixed in 2021.10.0

## Suggested inspection (read-only)
- `python -m pip show dask`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show distributed`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dask, distributed.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hwqr-f3v9-hwxr (OSV record GHSA-hwqr-f3v9-hwxr lists affected ranges: PyPI distributed >=0 <2021.10.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2021-387 (OSV record PYSEC-2021-387 lists affected ranges: PyPI dask >=0 <2021.10.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…