Embedded malware in ua-parser-js
CVE-2021-4229GHSA-pjwm-rvh2-c87w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ua-parser-js 1.0.1, 0.8.1, 0.7.30), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ua-parser-js
- Affected
- >= 0.7.29, <= 0.7.29>= 0.8.0, <= 0.8.0>= 1.0.0, <= 1.0.0
- Fixed in
- 0.8.1, 1.0.1, 0.7.30
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjwm-rvh2-c87w lists affected ranges: npm ua-parser-js >=0.7.29 =0.8.0 =1.0.0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjwm-rvh2-c87w lists affected ranges: npm ua-parser-js >=0.7.29 =0.8.0 =1.0.0 <=1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-4229: 1.52% estimated exploitation activity in the next 30 days; percentile 74.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The npm package ua-parser-js had three versions published with malicious code. Users of affected versions (0.7.29, 0.8.0, 1.0.0) should upgrade as soon as possible and check their systems for suspicious activity. See this issue for details as they unfold. Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pjwm-rvh2-c87w
- Revision 1 · created ·
Published from osv record GHSA-pjwm-rvh2-c87w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4229 Advisory: Embedded malware in ua-parser-js IDs: CVE-2021-4229, GHSA-pjwm-rvh2-c87w Record: https://patchnext.com/advisories/cve-2021-4229 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ua-parser-js 1.0.1, 0.8.1, 0.7.30. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ua-parser-js: affected >= 0.7.29, <= 0.7.29; >= 0.8.0, <= 0.8.0; >= 1.0.0, <= 1.0.0; fixed in 0.8.1, 1.0.1, 0.7.30 ## Suggested inspection (read-only) - `npm ls ua-parser-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ua-parser-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjwm-rvh2-c87w (OSV record GHSA-pjwm-rvh2-c87w lists affected ranges: npm ua-parser-js >=0.7.29 =0.8.0 =1.0.0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-pjwm-rvh2-c87w (GitHub-reviewed advisory GHSA-pjwm-rvh2-c87w lists affected ranges: npm ua-parser-js >=0.7.29 =0.8.0 =1.0.0 <=1.0.0) Commands are suggestions: review each one before running it.
Loading voting…