Skip to content

← Actionable
High, CVSS 7.5

Cookie Prefix Spoofing in CGI::Cookie.parse

CVE-2021-41819GHSA-4vf4-qmvg-mh7h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cgi 0.3.1, 0.2.1, 0.1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems cgi

    Affected
    >= 0.3.0, <= 0.3.0>= 0.2.0, <= 0.2.0< 0.1.0.1
    Fixed in
    0.3.1, 0.1.0.1, 0.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2021-41819: 3.15% estimated exploitation activity in the next 30 days; percentile 87.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem prior to versions 0.3.1, 0.2.1, 0.1.1, and 0.1.0.1 for Ruby.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4vf4-qmvg-mh7h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41819

Advisory: Cookie Prefix Spoofing in CGI::Cookie.parse
IDs: CVE-2021-41819, GHSA-4vf4-qmvg-mh7h
Record: https://patchnext.com/advisories/cve-2021-41819 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cgi 0.3.1, 0.2.1, 0.1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems cgi: affected >= 0.3.0, <= 0.3.0; >= 0.2.0, <= 0.2.0; < 0.1.0.1; fixed in 0.3.1, 0.1.0.1, 0.2.1

## Suggested inspection (read-only)
- RubyGems cgi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cgi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4vf4-qmvg-mh7h (GitHub-reviewed advisory GHSA-4vf4-qmvg-mh7h lists affected ranges: RubyGems cgi >=0.3.0 =0.2.0 =0 <0.1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…