Regular expression denial of service vulnerability (ReDoS) in date
CVE-2021-41817GHSA-qg54-694p-wgpp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (date 3.2.1, 3.1.2, 3.0.2, 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems date
- Affected
- >= 3.2.0, < 3.2.1>= 3.1.0, < 3.1.2>= 3.0.0, < 3.0.2< 2.0.1
- Fixed in
- 3.2.1, 2.0.1, 3.0.2, 3.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qg54-694p-wgpp lists affected ranges: RubyGems date >=3.2.0 =3.1.0 =3.0.0 =0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-41817: 3.46% estimated exploitation activity in the next 30 days; percentile 89.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Date’s parsing methods including Date.parse are using Regexps internally, some of which are vulnerable against regular expression denial of service. Applications and libraries that apply such methods to untrusted input may be affected. The fix limits the input length up to 128 bytes by default instead of changing the regexps. This is because Date gem uses many Regexps and it is possible that there are still undiscovered vulnerable Regexps. For compatibility, it is allowed to remove the limitation by explicitly passing limit keywords as nil like Date.parse(str, limit: nil), but note that it may take a long time to parse. Please update the date gem to version 3.2.1, 3.1.2, 3.0.2, and 2.0.1, or later. You can use gem update date to update it. If you are using bundler, please add gem "date", "= 3.2.1" to your Gemfile. If you import date from the standard library rather than as a gem you should update your Ruby install to 3.0.3, 2.7.5, 2.6.9 or later. Users unable to upgrade may consider…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qg54-694p-wgpp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41817 Advisory: Regular expression denial of service vulnerability (ReDoS) in date IDs: CVE-2021-41817, GHSA-qg54-694p-wgpp Record: https://patchnext.com/advisories/cve-2021-41817 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: date 3.2.1, 3.1.2, 3.0.2, 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems date: affected >= 3.2.0, < 3.2.1; >= 3.1.0, < 3.1.2; >= 3.0.0, < 3.0.2; < 2.0.1; fixed in 3.2.1, 2.0.1, 3.0.2, 3.1.2 ## Suggested inspection (read-only) - RubyGems date: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on date. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qg54-694p-wgpp (GitHub-reviewed advisory GHSA-qg54-694p-wgpp lists affected ranges: RubyGems date >=3.2.0 =3.1.0 =3.0.0 =0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…