fabric8 kubernetes-client vulnerable
CVE-2021-4178GHSA-98g7-rxmf-rrxm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.fabric8:kubernetes-client 5.11.2, 5.10.2, 5.8.1, 5.7.4, 5.3.2, 5.1.2, 5.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.fabric8:kubernetes-client
- Affected
- >= 5.0.0-beta-1, < 5.0.3>= 5.1.0, < 5.1.2>= 5.2.0, < 5.3.2>= 5.5.0, < 5.7.4>= 5.8.0, < 5.8.1>= 5.9.0, < 5.10.2>= 5.11.0, < 5.11.2
- Fixed in
- 5.3.2, 5.11.2, 5.10.2, 5.7.4, 5.0.3, 5.1.2, 5.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98g7-rxmf-rrxm lists affected ranges: Maven io.fabric8:kubernetes-client >=5.0.0-beta-1 =5.1.0 =5.2.0 =5.5.0 =5.8.0 =5.9.0 =5.11.0 <5.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-4178: 0.34% estimated exploitation activity in the next 30 days; percentile 27.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
fabric8 Kubernetes client had an arbitrary code execution flaw in versions 5.0.0-beta-1 and higher. Attackers could potentially insert malicious YAMLs due to misconfigured YAML parsing.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-98g7-rxmf-rrxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4178 Advisory: fabric8 kubernetes-client vulnerable IDs: CVE-2021-4178, GHSA-98g7-rxmf-rrxm Record: https://patchnext.com/advisories/cve-2021-4178 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.fabric8:kubernetes-client 5.11.2, 5.10.2, 5.8.1, 5.7.4, 5.3.2, 5.1.2, 5.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.fabric8:kubernetes-client: affected >= 5.0.0-beta-1, < 5.0.3; >= 5.1.0, < 5.1.2; >= 5.2.0, < 5.3.2; >= 5.5.0, < 5.7.4; >= 5.8.0, < 5.8.1; >= 5.9.0, < 5.10.2; >= 5.11.0, < 5.11.2; fixed in 5.3.2, 5.11.2, 5.10.2, 5.7.4, 5.0.3, 5.1.2, 5.8.1 ## Suggested inspection (read-only) - Maven io.fabric8:kubernetes-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.fabric8:kubernetes-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98g7-rxmf-rrxm (GitHub-reviewed advisory GHSA-98g7-rxmf-rrxm lists affected ranges: Maven io.fabric8:kubernetes-client >=5.0.0-beta-1 =5.1.0 =5.2.0 =5.5.0 =5.8.0 =5.9.0 =5.11.0 <5.11.2) Commands are suggestions: review each one before running it.
Loading voting…