Cross-site Scripting in SEOmatic plugin
CVE-2021-41750GHSA-6hjc-m38h-7jhh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nystudio107/craft-seomatic 3.4.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist nystudio107/craft-seomatic
- Affected
- < 3.4.11
- Fixed in
- 3.4.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6hjc-m38h-7jhh lists affected ranges: Packagist nystudio107/craft-seomatic >=0 <3.4.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-41750: 1.13% estimated exploitation activity in the next 30 days; percentile 66.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cross-site scripting (XSS) vulnerability in the SEOmatic plugin 3.4.10 for Craft CMS 3 allows remote attackers to inject arbitrary web script via a GET to /index.php?action=seomatic/file/seo-file-link with url parameter containing the base64 encoded URL of a malicious web page / file and fileName parameter containing an arbitrary filename with the intended content-type to be rendered in the user's browser as the extension.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6hjc-m38h-7jhh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41750 Advisory: Cross-site Scripting in SEOmatic plugin IDs: CVE-2021-41750, GHSA-6hjc-m38h-7jhh Record: https://patchnext.com/advisories/cve-2021-41750 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nystudio107/craft-seomatic 3.4.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist nystudio107/craft-seomatic: affected < 3.4.11; fixed in 3.4.11 ## Suggested inspection (read-only) - Packagist nystudio107/craft-seomatic: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nystudio107/craft-seomatic. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6hjc-m38h-7jhh (GitHub-reviewed advisory GHSA-6hjc-m38h-7jhh lists affected ranges: Packagist nystudio107/craft-seomatic >=0 <3.4.11) Commands are suggestions: review each one before running it.
Loading voting…