Spree Auth Devise vulnerability allows for authentication bypass through CSRF weakness
CVE-2021-41275GHSA-26xx-m4q2-xhq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree_auth_devise 4.4.1, 4.2.1, 4.1.1, 4.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems spree_auth_devise
- Affected
- >= 4.3.0, < 4.4.1>= 4.2.0, < 4.2.1>= 4.1.0, < 4.1.1< 4.0.1
- Fixed in
- 4.2.1, 4.4.1, 4.1.1, 4.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-26xx-m4q2-xhq8 lists affected ranges: RubyGems spree_auth_devise >=4.3.0 =4.2.0 =4.1.0 =0 <4.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2021-41275: 0.65% estimated exploitation activity in the next 30 days; percentile 51.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of spreeauthdevise are affected if protectfromforgery method is both: Executed whether as: A beforeaction callback (the default) A prependbeforeaction (option prepend: true given) before the :loadobject hook in Spree::UserController (most likely order to find). Configured to use :nullsession or :resetsession strategies (:nullsession is the default in case the no strategy is given, but rails --new generated skeleton use :exception). That means that applications that haven't been configured differently from what it's generated with Rails aren't affected. Thanks @waiting-for-dev for reporting and providing a patch 👏 Patches Spree 4.3 users should update to spreeauthdevise 4.4.1 Spree 4.2 users should update to spreeauthdevise 4.2.1 Spree 4.1 users should update to spreeauthdevise 4.1.1 Older Spree version users should update to spreeauthdevise 4.0.1 Workarounds If…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-26xx-m4q2-xhq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41275 Advisory: Spree Auth Devise vulnerability allows for authentication bypass through CSRF weakness IDs: CVE-2021-41275, GHSA-26xx-m4q2-xhq8 Record: https://patchnext.com/advisories/cve-2021-41275 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spree_auth_devise 4.4.1, 4.2.1, 4.1.1, 4.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems spree_auth_devise: affected >= 4.3.0, < 4.4.1; >= 4.2.0, < 4.2.1; >= 4.1.0, < 4.1.1; < 4.0.1; fixed in 4.2.1, 4.4.1, 4.1.1, 4.0.1 ## Suggested inspection (read-only) - RubyGems spree_auth_devise: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spree_auth_devise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-26xx-m4q2-xhq8 (GitHub-reviewed advisory GHSA-26xx-m4q2-xhq8 lists affected ranges: RubyGems spree_auth_devise >=4.3.0 =4.2.0 =4.1.0 =0 <4.0.1) Commands are suggestions: review each one before running it.
Loading voting…