Skip to content

← Actionable
Critical, CVSS 9.3

Authentication Bypass by CSRF Weakness

CVE-2021-41274GHSA-xm34-v85h-9pg2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (solidus_auth_devise 2.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-41274: 0.73% estimated exploitation activity in the next 30 days; percentile 54.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact CSRF vulnerability that allows user account takeover. All applications using any version of the frontend component of solidusauthdevise are affected if protectfromforgery method is both: - Executed whether as: - A beforeaction callback (the default) - A prependbeforeaction (option prepend: true given) before the :loadobject hook in Spree::UserController (most likely order to find). - Configured to use :nullsession or :resetsession strategies (:nullsession is the default in case the no strategy is given, but rails --new generated skeleton use :exception). That means that applications that haven't been configured differently from what it's generated with Rails aren't affected. Patches Users should promptly update to solidusauthdevise version 2.5.4. Workarounds A couple of options: - If possible, change your strategy to :exception: - Add the following to config/application.rb to at least run the :exception strategy on the affected controller: - We've also released new Solidus…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xm34-v85h-9pg2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41274

Advisory: Authentication Bypass by CSRF Weakness
IDs: CVE-2021-41274, GHSA-xm34-v85h-9pg2
Record: https://patchnext.com/advisories/cve-2021-41274 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: solidus_auth_devise 2.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems solidus_auth_devise: affected >= 1.0.0, < 2.5.4; fixed in 2.5.4

## Suggested inspection (read-only)
- RubyGems solidus_auth_devise: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on solidus_auth_devise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xm34-v85h-9pg2 (GitHub-reviewed advisory GHSA-xm34-v85h-9pg2 lists affected ranges: RubyGems solidus_auth_devise >=1.0.0 <2.5.4)

Commands are suggestions: review each one before running it.

Loading voting…