Cross-Site Request Forgery allowing sending of test emails and generation of node auto-deployment keys
CVE-2021-41273GHSA-wwgq-9jhf-qgw6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pterodactyl/panel
- Affected
- < 1.6.6
- Fixed in
- 1.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wwgq-9jhf-qgw6 lists affected ranges: Packagist pterodactyl/panel >=0 <1.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- EPSS
- CVE-2021-41273: 0.39% estimated exploitation activity in the next 30 days; percentile 33.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to improperly configured CSRF protections on two routes, a malicious user could execute a CSRF-based attack against the following endpoints: Sending a test email. Generating a node auto-deployment token. At no point would any data be exposed to the malicious user, this would simply trigger email spam to an administrative user, or generate a single auto-deployment token unexpectedly. This token is not revealed to the malicious user, it is simply created unexpectedly in the system. Patches This has been addressed in https://github.com/pterodactyl/panel/commit/bf9cbe2c6d5266c6914223e067c56175de7fc3a5 which will be released as 1.6.6. Workarounds Users may optionally manually apply the fixes released in v1.6.6 to patch their own systems.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wwgq-9jhf-qgw6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41273 Advisory: Cross-Site Request Forgery allowing sending of test emails and generation of node auto-deployment keys IDs: CVE-2021-41273, GHSA-wwgq-9jhf-qgw6 Record: https://patchnext.com/advisories/cve-2021-41273 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pterodactyl/panel: affected < 1.6.6; fixed in 1.6.6 ## Suggested inspection (read-only) - Packagist pterodactyl/panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pterodactyl/panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wwgq-9jhf-qgw6 (GitHub-reviewed advisory GHSA-wwgq-9jhf-qgw6 lists affected ranges: Packagist pterodactyl/panel >=0 <1.6.6) Commands are suggestions: review each one before running it.
Loading voting…