CSV Injection in symfony/serializer
CVE-2021-41270GHSA-2xhg-w2g5-w95x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 5.3.12, 4.4.35; symfony/serializer 5.3.12, 4.4.35), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 4.1.0, < 4.4.35>= 5.0.0, < 5.3.12
- Fixed in
- 5.3.12, 4.4.35
Packagist symfony/serializer
- Affected
- >= 5.0.0, < 5.3.12>= 4.1.0, < 4.4.35
- Fixed in
- 5.3.12, 4.4.35
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2xhg-w2g5-w95x lists affected ranges: Packagist symfony/serializer >=5.0.0 =4.1.0 =4.1.0 =5.0.0 <5.3.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-41270: 1.40% estimated exploitation activity in the next 30 days; percentile 72.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description ----------- CSV Injection, also known as Formula Injection, occurs when websites embed untrusted input inside CSV files. When a spreadsheet program opens a CSV, any cell starting with = is interpreted by the software as a formula and could be abused by an attacker. In Symfony 4.1, we've added the opt-in csvescapeformulas option in CsvEncoder, to prefix all cells starting by =, +, - or @ by a tab \t. Since then, OWASP added 2 chars in that list: - Tab (0x09) - Carriage return (0x0D) This makes our previous prefix char (Tab \t) part of the vulnerable characters, and OWASP suggests using the single quote ' for prefixing the value. Resolution ---------- Symfony now follows the OWASP recommendations and use the single quote ' to prefix formulas and adds the prefix to cells starting by \t, \r as well as =, +, - and @. The patch for this issue is available here for branch 4.4. Credits ------- We would like to thank Jake Barwell for reporting the issue and Jérémy Derussé for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2xhg-w2g5-w95x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41270 Advisory: CSV Injection in symfony/serializer IDs: CVE-2021-41270, GHSA-2xhg-w2g5-w95x Record: https://patchnext.com/advisories/cve-2021-41270 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 5.3.12, 4.4.35; symfony/serializer 5.3.12, 4.4.35. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 4.1.0, < 4.4.35; >= 5.0.0, < 5.3.12; fixed in 5.3.12, 4.4.35 - Packagist symfony/serializer: affected >= 5.0.0, < 5.3.12; >= 4.1.0, < 4.4.35; fixed in 5.3.12, 4.4.35 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/serializer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/serializer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2xhg-w2g5-w95x (GitHub-reviewed advisory GHSA-2xhg-w2g5-w95x lists affected ranges: Packagist symfony/serializer >=5.0.0 =4.1.0 =4.1.0 =5.0.0 <5.3.12) Commands are suggestions: review each one before running it.
Loading voting…