UUPSUpgradeable vulnerability in @openzeppelin/contracts
CVE-2021-41264GHSA-5vp3-v4hc-gx76
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.3.2; @openzeppelin/contracts-upgradeable 4.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.1.0, < 4.3.2
- Fixed in
- 4.3.2
npm @openzeppelin/contracts-upgradeable
- Affected
- >= 4.1.0, < 4.3.2
- Fixed in
- 4.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5vp3-v4hc-gx76 lists affected ranges: npm @openzeppelin/contracts >=4.1.0 =4.1.0 <4.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vp3-v4hc-gx76 lists affected ranges: npm @openzeppelin/contracts >=4.1.0 =4.1.0 <4.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-41264: 1.49% estimated exploitation activity in the next 30 days; percentile 74.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Upgradeable contracts using UUPSUpgradeable may be vulnerable to an attack affecting uninitialized implementation contracts. We will update this advisory with more information soon. Patches A fix is included in version 4.3.2 of @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. Workarounds Initialize implementation contracts using UUPSUpgradeable by invoking the initializer function (usually called initialize). An example is provided in the forum. References Post-mortem. For more information If you have any questions or comments about this advisory, or need assistance executing the mitigation, email us at security@openzeppelin.com.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5vp3-v4hc-gx76
- Revision 1 · created ·
Published from osv record GHSA-5vp3-v4hc-gx76
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41264 Advisory: UUPSUpgradeable vulnerability in @openzeppelin/contracts IDs: CVE-2021-41264, GHSA-5vp3-v4hc-gx76 Record: https://patchnext.com/advisories/cve-2021-41264 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.3.2; @openzeppelin/contracts-upgradeable 4.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @openzeppelin/contracts: affected >= 4.1.0, < 4.3.2; fixed in 4.3.2 - npm @openzeppelin/contracts-upgradeable: affected >= 4.1.0, < 4.3.2; fixed in 4.3.2 ## Suggested inspection (read-only) - `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5vp3-v4hc-gx76 (OSV record GHSA-5vp3-v4hc-gx76 lists affected ranges: npm @openzeppelin/contracts >=4.1.0 =4.1.0 <4.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-5vp3-v4hc-gx76 (GitHub-reviewed advisory GHSA-5vp3-v4hc-gx76 lists affected ranges: npm @openzeppelin/contracts >=4.1.0 =4.1.0 <4.3.2) Commands are suggestions: review each one before running it.
Loading voting…