Skip to content

← Actionable
Medium, CVSS 6.2

Rails Multisite secure/signed cookies share secrets between sites in a multi-site application

CVE-2021-41263GHSA-844m-cpr9-jcmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails_multisite 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:H
EPSS
  • CVE-2021-41263: 0.63% estimated exploitation activity in the next 30 days; percentile 50.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability impacts any Rails applications using railsmultisite alongside Rails' signed/encrypted cookies. Depending on how the application makes use of these cookies, it may be possible for an attacker to re-use cookies on different 'sites' within a multi-site Rails application. Patches The issue has been patched in v4 of the railsmultisite gem. Note that this upgrade will invalidate all previous signed/encrypted cookies. The impact of this invalidation will vary based on the application architecture.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-844m-cpr9-jcmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41263

Advisory: Rails Multisite secure/signed cookies share secrets between sites in a multi-site application
IDs: CVE-2021-41263, GHSA-844m-cpr9-jcmh
Record: https://patchnext.com/advisories/cve-2021-41263 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rails_multisite 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rails_multisite: affected < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- RubyGems rails_multisite: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rails_multisite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-844m-cpr9-jcmh (GitHub-reviewed advisory GHSA-844m-cpr9-jcmh lists affected ranges: RubyGems rails_multisite >=0 <4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…