Skip to content

← Actionable
High, CVSS 7.1amended

GraphiQL introspection schema template injection attack

CVE-2021-41248GHSA-x4r7-m2q9-69c8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphiql 1.4.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm graphiql

    Affected
    >= 0.5.0, < 1.4.7
    Fixed in
    1.4.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2021-41248: 1.26% estimated exploitation activity in the next 30 days; percentile 69.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

- 1. Impact - 2. Scope - 3. Patches - 3.1 CDN bundle implementations may be automatically patched - 4. Workarounds for Older Versions - 5. How to Re-create the Exploit - 6. Credit - 7. References - 8. For more information This is a security advisory for an XSS vulnerability in graphiql. A similar vulnerability affects graphql-playground, a fork of graphiql. There is a corresponding graphql-playground advisory and Apollo Server advisory. 1. Impact All versions of graphiql older than graphiql@1.4.7 are vulnerable to compromised HTTP schema introspection responses or schema prop values with malicious GraphQL type names, exposing a dynamic XSS attack surface that can allow code injection on operation autocomplete. In order for the attack to take place, the user must load a vulnerable schema in graphiql. There are a number of ways that can occur. By default, the schema URL is not attacker-controllable in graphiql or in its suggested implementations or examples, leaving only very complex…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x4r7-m2q9-69c8

  2. Revision 1 · created ·

    Published from osv record GHSA-x4r7-m2q9-69c8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41248

Advisory: GraphiQL introspection schema template injection attack
IDs: CVE-2021-41248, GHSA-x4r7-m2q9-69c8
Record: https://patchnext.com/advisories/cve-2021-41248 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: graphiql 1.4.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm graphiql: affected >= 0.5.0, < 1.4.7; fixed in 1.4.7

## Suggested inspection (read-only)
- `npm ls graphiql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on graphiql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x4r7-m2q9-69c8 (OSV record GHSA-x4r7-m2q9-69c8 lists affected ranges: npm graphiql >=0.5.0 <1.4.7 (fixed))
- Verified: https://github.com/advisories/GHSA-x4r7-m2q9-69c8 (GitHub-reviewed advisory GHSA-x4r7-m2q9-69c8 lists affected ranges: npm graphiql >=0.5.0 <1.4.7)

Commands are suggestions: review each one before running it.

Loading voting…