DataFlow upload remote code execution vulnerability
CVE-2021-41231GHSA-h632-p764-pjqm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.0.19, 19.4.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist openmage/magento-lts
- Affected
- < 19.4.22>= 20.0.0, < 20.0.19
- Fixed in
- 20.0.19, 19.4.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h632-p764-pjqm lists affected ranges: Packagist openmage/magento-lts >=0 =20.0.0 <20.0.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-41231: 1.23% estimated exploitation activity in the next 30 days; percentile 69.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h632-p764-pjqm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41231 Advisory: DataFlow upload remote code execution vulnerability IDs: CVE-2021-41231, GHSA-h632-p764-pjqm Record: https://patchnext.com/advisories/cve-2021-41231 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.0.19, 19.4.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist openmage/magento-lts: affected < 19.4.22; >= 20.0.0, < 20.0.19; fixed in 20.0.19, 19.4.22 ## Suggested inspection (read-only) - Packagist openmage/magento-lts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openmage/magento-lts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h632-p764-pjqm (GitHub-reviewed advisory GHSA-h632-p764-pjqm lists affected ranges: Packagist openmage/magento-lts >=0 =20.0.0 <20.0.19) Commands are suggestions: review each one before running it.
Loading voting…