Skip to content

← Actionable
Medium, CVSS 5.3

OIDC claims not updated from Identity Provider in Pomerium

CVE-2021-41230GHSA-j6wp-3859-vxfg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.15.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-41230: 0.86% estimated exploitation activity in the next 30 days; percentile 58.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Changes to the OIDC claims of a user after initial login are not reflected in policy evaluation when using allowedidpclaims as part of policy. If using allowedidpclaims and a user's claims are changed, Pomerium can make incorrect authorization decisions. Patches v0.15.6 Workarounds - Clear data on databroker service by clearing redis or restarting the in-memory databroker to force claims to be updated References https://github.com/pomerium/pomerium/pull/2724 For more information If you have any questions or comments about this advisory: Open an issue in Pomerium Email us at security@pomerium.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j6wp-3859-vxfg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41230

Advisory: OIDC claims not updated from Identity Provider in Pomerium
IDs: CVE-2021-41230, GHSA-j6wp-3859-vxfg
Record: https://patchnext.com/advisories/cve-2021-41230 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.15.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pomerium/pomerium: affected >= 0.14.0, < 0.15.6; fixed in 0.15.6

## Suggested inspection (read-only)
- Go github.com/pomerium/pomerium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pomerium/pomerium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j6wp-3859-vxfg (GitHub-reviewed advisory GHSA-j6wp-3859-vxfg lists affected ranges: Go github.com/pomerium/pomerium >=0.14.0 <0.15.6)

Commands are suggestions: review each one before running it.

Loading voting…