Undefined behavior via nullptr reference binding in sparse matrix multiplication
CVE-2021-41219GHSA-4f99-p9c2-3j8x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.6.1, 2.5.2, 2.4.4; tensorflow-gpu 2.6.1, 2.5.2, 2.4.4; tensorflow-cpu 2.6.1, 2.5.2, 2.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
- Fixed in
- 2.5.2, 2.4.4, 2.6.1
PyPI tensorflow-gpu
- Affected
- >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
- Fixed in
- 2.5.2, 2.4.4, 2.6.1
PyPI tensorflow-cpu
- Affected
- >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
- Fixed in
- 2.5.2, 2.4.4, 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4f99-p9c2-3j8x lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4f99-p9c2-3j8x lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-41219: 0.21% estimated exploitation activity in the next 30 days; percentile 11.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The code for sparse matrix multiplication is vulnerable to undefined behavior via binding a reference to nullptr: This occurs whenever the dimensions of a or b are 0 or less. In the case on one of these is 0, an empty output tensor should be allocated (to conserve the invariant that output tensors are always allocated when the operation is successful) but nothing should be written to it (that is, we should return early from the kernel implementation). Otherwise, attempts to write to this empty tensor would result in heap OOB access. Patches We have patched the issue in GitHub commit e6cf28c72ba2eb949ca950d834dd6d66bb01cfae. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4f99-p9c2-3j8x
- Revision 1 · created ·
Published from osv record GHSA-4f99-p9c2-3j8x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41219 Advisory: Undefined behavior via `nullptr` reference binding in sparse matrix multiplication IDs: CVE-2021-41219, GHSA-4f99-p9c2-3j8x Record: https://patchnext.com/advisories/cve-2021-41219 (revision 2, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.6.1, 2.5.2, 2.4.4; tensorflow-gpu 2.6.1, 2.5.2, 2.4.4; tensorflow-cpu 2.6.1, 2.5.2, 2.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1 - PyPI tensorflow-gpu: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1 - PyPI tensorflow-cpu: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4f99-p9c2-3j8x (OSV record GHSA-4f99-p9c2-3j8x lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4 (fixed)) - Verified: https://github.com/advisories/GHSA-4f99-p9c2-3j8x (GitHub-reviewed advisory GHSA-4f99-p9c2-3j8x lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4) Commands are suggestions: review each one before running it.
Loading voting…