Skip to content

← Actionable
High, CVSS 7.3amended

Incomplete validation of shapes in multiple TF ops

CVE-2021-41206GHSA-pgcq-h79j-2f69

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.6.1, 2.5.2, 2.4.4; tensorflow-gpu 2.6.1, 2.5.2, 2.4.4; tensorflow-cpu 2.6.1, 2.5.2, 2.4.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
    Fixed in
    2.5.2, 2.4.4, 2.6.1
  • PyPI tensorflow-gpu

    Affected
    >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
    Fixed in
    2.5.2, 2.4.4, 2.6.1
  • PyPI tensorflow-cpu

    Affected
    >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
    Fixed in
    2.5.2, 2.4.4, 2.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-41206: 0.18% estimated exploitation activity in the next 30 days; percentile 7.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Several TensorFlow operations are missing validation for the shapes of the tensor arguments involved in the call. Depending on the API, this can result in undefined behavior and segfault or CHECK-fail related crashes but in some scenarios writes and reads from heap populated arrays are also possible. We have discovered these issues internally via tooling while working on improving/testing GPU op determinism. As such, we don't have reproducers and there will be multiple fixes for these issues. Patches We have patched the issue in GitHub commits 68422b215e618df5ad375bcdc6d2052e9fd3080a, 4d74d8a00b07441cba090a02e0dd9ed385145bf4, 579261dcd446385831fe4f7457d802a59685121d, da4aad5946be30e5f049920fa076e1f7ef021261, 4dddb2fd0b01cdd196101afbba6518658a2c9e07, and e7f497570abb6b4ae5af4970620cd880e4c0c904. These fixes will be included in TensorFlow 2.7.0. We will also cherrypick these commits on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pgcq-h79j-2f69

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pgcq-h79j-2f69

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41206

Advisory: Incomplete validation of shapes in multiple TF ops
IDs: CVE-2021-41206, GHSA-pgcq-h79j-2f69
Record: https://patchnext.com/advisories/cve-2021-41206 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.6.1, 2.5.2, 2.4.4; tensorflow-gpu 2.6.1, 2.5.2, 2.4.4; tensorflow-cpu 2.6.1, 2.5.2, 2.4.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1
- PyPI tensorflow-gpu: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1
- PyPI tensorflow-cpu: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pgcq-h79j-2f69 (OSV record GHSA-pgcq-h79j-2f69 lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4 (fixed))
- Verified: https://github.com/advisories/GHSA-pgcq-h79j-2f69 (GitHub-reviewed advisory GHSA-pgcq-h79j-2f69 lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4)

Commands are suggestions: review each one before running it.

Loading voting…