Crashes due to overflow and CHECK-fail in ops with large tensor shapes
CVE-2021-41197GHSA-prcg-wp5q-rv7p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.6.1, 2.5.2, 2.4.4; tensorflow-gpu 2.6.1, 2.5.2, 2.4.4; tensorflow-cpu 2.6.1, 2.5.2, 2.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
- Fixed in
- 2.5.2, 2.4.4, 2.6.1
PyPI tensorflow-gpu
- Affected
- >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
- Fixed in
- 2.5.2, 2.4.4, 2.6.1
PyPI tensorflow-cpu
- Affected
- >= 2.6.0, < 2.6.1>= 2.5.0, < 2.5.2< 2.4.4
- Fixed in
- 2.5.2, 2.4.4, 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-prcg-wp5q-rv7p lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-prcg-wp5q-rv7p lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-41197: 0.32% estimated exploitation activity in the next 30 days; percentile 24.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact TensorFlow allows tensor to have a large number of dimensions and each dimension can be as large as desired. However, the total number of elements in a tensor must fit within an int64t. If an overflow occurs, MultiplyWithoutOverflow would return a negative result. In the majority of TensorFlow codebase this then results in a CHECK-failure. Newer constructs exist which return a Status instead of crashing the binary. For example AddDim calls should be replaced by AddDimWithStatus. This is similar to CVE-2021-29584 (and similar other reported vulnerabilities in TensorFlow, localized to specific APIs). Patches We have patched the issue in GitHub commits 7c1692bd417eb4f9b33ead749a41166d6080af85 (merging #51732), d81b1351da3e8c884ff836b64458d94e4a157c15 (merging #51717), a871989d7b6c18cdebf2fb4f0e5c5b62fbc19edf (merging #51658), and d81b1351da3e8c884ff836b64458d94e4a157c15 (merging #51973). It is possible that other similar instances exist in TensorFlow, we will issue fixes as these…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-prcg-wp5q-rv7p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-prcg-wp5q-rv7p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41197 Advisory: Crashes due to overflow and `CHECK`-fail in ops with large tensor shapes IDs: CVE-2021-41197, GHSA-prcg-wp5q-rv7p Record: https://patchnext.com/advisories/cve-2021-41197 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.6.1, 2.5.2, 2.4.4; tensorflow-gpu 2.6.1, 2.5.2, 2.4.4; tensorflow-cpu 2.6.1, 2.5.2, 2.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1 - PyPI tensorflow-gpu: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1 - PyPI tensorflow-cpu: affected >= 2.6.0, < 2.6.1; >= 2.5.0, < 2.5.2; < 2.4.4; fixed in 2.5.2, 2.4.4, 2.6.1 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-prcg-wp5q-rv7p (OSV record GHSA-prcg-wp5q-rv7p lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4 (fixed)) - Verified: https://github.com/advisories/GHSA-prcg-wp5q-rv7p (GitHub-reviewed advisory GHSA-prcg-wp5q-rv7p lists affected ranges: PyPI tensorflow >=2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 =2.6.0 =2.5.0 =0 <2.4.4) Commands are suggestions: review each one before running it.
Loading voting…