Skip to content

← Actionable
Critical, CVSS 9.8

Use of Externally-Controlled Format String in wire-avs

CVE-2021-41193GHSA-2j6v-xpf3-xvrv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.wire:avs 7.1.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-41193: 2.47% estimated exploitation activity in the next 30 days; percentile 84.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote format string vulnerability allowed an attacker to cause a denial of service or possibly execute arbitrary code. Patches The issue has been fixed in wire-avs 7.1.12 and is already included on all Wire products (currently used version is 8.0.x) Workarounds No workaround known References Fixed in commit https://github.com/wireapp/wire-avs/commit/40d373ede795443ae6f2f756e9fb1f4f4ae90bbe For more information If you have any questions or comments about this advisory feel free to email us at vulnerability-report@wire.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2j6v-xpf3-xvrv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41193

Advisory: Use of Externally-Controlled Format String in wire-avs
IDs: CVE-2021-41193, GHSA-2j6v-xpf3-xvrv
Record: https://patchnext.com/advisories/cve-2021-41193 (revision 1, source checked 26 Oct 2026, 16:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.wire:avs 7.1.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.wire:avs: affected < 7.1.12; fixed in 7.1.12

## Suggested inspection (read-only)
- Maven com.wire:avs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.wire:avs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2j6v-xpf3-xvrv (GitHub-reviewed advisory GHSA-2j6v-xpf3-xvrv lists affected ranges: Maven com.wire:avs >=0 <7.1.12)

Commands are suggestions: review each one before running it.

Loading voting…