Skip to content

← Actionable
Medium, CVSS 5.3

BookStack is vulnerable to Improper Access Control.

CVE-2021-4119GHSA-9c5c-5j4h-8q2c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ssddanbrown/bookstack 21.11.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2021-4119: 26.89% estimated exploitation activity in the next 30 days; percentile 98.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

BookStack prior to version 21.11.3 is vulnerable to Improper Access Control. A logged-in user with no privileges OR guest user (if public access enabled) can access the /search/users/select AJAX endpoint meant for admins to manage audit logs, to dump all usernames existing in the Bookstack database. This can also be used to harvest email belonging to a user because BookStack also uses the code where(email, like, % . $search . %) to search for users based on email.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9c5c-5j4h-8q2c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-4119

Advisory: BookStack is vulnerable to Improper Access Control.
IDs: CVE-2021-4119, GHSA-9c5c-5j4h-8q2c
Record: https://patchnext.com/advisories/cve-2021-4119 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ssddanbrown/bookstack 21.11.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ssddanbrown/bookstack: affected < 21.11.3; fixed in 21.11.3

## Suggested inspection (read-only)
- Packagist ssddanbrown/bookstack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ssddanbrown/bookstack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9c5c-5j4h-8q2c (GitHub-reviewed advisory GHSA-9c5c-5j4h-8q2c lists affected ranges: Packagist ssddanbrown/bookstack >=0 <21.11.3)

Commands are suggestions: review each one before running it.

Loading voting…