ReDoS vulnerability in parser_apache2
CVE-2021-41186GHSA-hwhf-64mh-r662
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fluentd 1.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems fluentd
- Affected
- >= 0.14.14, < 1.14.2
- Fixed in
- 1.14.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hwhf-64mh-r662 lists affected ranges: RubyGems fluentd >=0.14.14 <1.14.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-41186: 2.21% estimated exploitation activity in the next 30 days; percentile 82.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact parserapache2 plugin in Fluentd v0.14.14 to v1.14.1 suffers from a regular expression denial of service (ReDoS) vulnerability. A broken apache log with a certain pattern of string can spend too much time in a regular expression, resulting in the potential for a DoS attack. Patches v1.14.2 Workarounds Either of the following: Don't use parserapache2 for parsing logs which cannot guarantee generated by Apache. Put patched version of parserapache2.rb into /etc/fluent/plugin directory (or any other directories specified by the environment variable FLUENTPLUGIN or --plugin option of fluentd). References CVE-2021-41186 GHSA-hwhf-64mh-r662 GHSL-2021-102 https://github.com/fluent/fluentd/blob/master/CHANGELOG.md#v1142
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hwhf-64mh-r662
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41186 Advisory: ReDoS vulnerability in parser_apache2 IDs: CVE-2021-41186, GHSA-hwhf-64mh-r662 Record: https://patchnext.com/advisories/cve-2021-41186 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fluentd 1.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems fluentd: affected >= 0.14.14, < 1.14.2; fixed in 1.14.2 ## Suggested inspection (read-only) - RubyGems fluentd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fluentd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hwhf-64mh-r662 (GitHub-reviewed advisory GHSA-hwhf-64mh-r662 lists affected ranges: RubyGems fluentd >=0.14.14 <1.14.2) Commands are suggestions: review each one before running it.
Loading voting…