Skip to content

← Actionable
Medium, CVSS 6.5amended

XSS in the altField option of the Datepicker widget in jquery-ui

CVE-2021-41182GHSA-9gj3-hwp5-pmwc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.webjars.npm:jquery-ui 1.13.0; jquery.ui.combined 1.13.0; jquery-ui 1.13.0; jquery-ui-rails 7.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2021-41182: 39.36% estimated exploitation activity in the next 30 days; percentile 98.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Accepting the value of the altField option of the Datepicker widget from untrusted sources may execute untrusted code. For example, initializing the datepicker in the following way: will call the doEvilThing function. Patches The issue is fixed in jQuery UI 1.13.0. Any string value passed to the altField option is now treated as a CSS selector. Workarounds A workaround is to not accept the value of the altField option from untrusted sources. For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery UI repo. If you don't find an answer, open a new issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9gj3-hwp5-pmwc

  2. Revision 1 · created ·

    Published from osv record GHSA-9gj3-hwp5-pmwc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41182

Advisory: XSS in the `altField` option of the Datepicker widget in jquery-ui
IDs: CVE-2021-41182, GHSA-9gj3-hwp5-pmwc
Record: https://patchnext.com/advisories/cve-2021-41182 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.webjars.npm:jquery-ui 1.13.0; jquery.ui.combined 1.13.0; jquery-ui 1.13.0; jquery-ui-rails 7.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.webjars.npm:jquery-ui: affected < 1.13.0; fixed in 1.13.0
- NuGet jquery.ui.combined: affected < 1.13.0; fixed in 1.13.0
- npm jquery-ui: affected < 1.13.0; fixed in 1.13.0
- RubyGems jquery-ui-rails: affected < 7.0.0; fixed in 7.0.0

## Suggested inspection (read-only)
- Maven org.webjars.npm:jquery-ui: check the installed version with your package manager.
- NuGet jquery.ui.combined: check the installed version with your package manager.
- `npm ls jquery-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- RubyGems jquery-ui-rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.webjars.npm:jquery-ui, jquery.ui.combined, jquery-ui, jquery-ui-rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9gj3-hwp5-pmwc (OSV record GHSA-9gj3-hwp5-pmwc lists affected ranges: npm jquery-ui >=0 =0 =0 =0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9gj3-hwp5-pmwc (GitHub-reviewed advisory GHSA-9gj3-hwp5-pmwc lists affected ranges: npm jquery-ui >=0 =0 =0 =0 <7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…