Skip to content

← Actionable
Unrated

pterodactyl/panel CSRF allowing an external page to trigger a user logout event

CVE-2021-41176GHSA-m49f-hcxp-6hm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-41176: 0.52% estimated exploitation activity in the next 30 days; percentile 44.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious user can trigger a user logout if a signed in user visits a malicious website that makes a request to the Panel's sign-out endpoint. This requires a targeted attack against a specific Panel instance, and serves only to sign a user out. No user details are leaked, nor is any user data affected, this is simply an annoyance at worst. Patches None. Workarounds None. For more information If you have any questions or comments about this advisory please contact Tactical Fish#8008 on Discord, or email dane@pterodactyl.io.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m49f-hcxp-6hm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41176

Advisory: pterodactyl/panel CSRF allowing an external page to trigger a user logout event
IDs: CVE-2021-41176, GHSA-m49f-hcxp-6hm6
Record: https://patchnext.com/advisories/cve-2021-41176 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pterodactyl/panel: affected >= 1.0.0, < 1.6.3; fixed in 1.6.3

## Suggested inspection (read-only)
- Packagist pterodactyl/panel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pterodactyl/panel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m49f-hcxp-6hm6 (GitHub-reviewed advisory GHSA-m49f-hcxp-6hm6 lists affected ranges: Packagist pterodactyl/panel >=1.0.0 <1.6.3)

Commands are suggestions: review each one before running it.

Loading voting…