XSS vulnerability allowing arbitrary JavaScript execution
CVE-2021-41174GHSA-3j9m-hcv9-rpj8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grafana/data 8.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @grafana/data
- Affected
- >= 8.0.0, < 8.2.3
- Fixed in
- 8.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3j9m-hcv9-rpj8 lists affected ranges: npm @grafana/data >=8.0.0 <8.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3j9m-hcv9-rpj8 lists affected ranges: npm @grafana/data >=8.0.0 <8.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
- EPSS
- CVE-2021-41174: 85.40% estimated exploitation activity in the next 30 days; percentile 99.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Today we are releasing Grafana 8.2.3. This patch release includes an important security fix for an issue that affects all Grafana versions from 8.0.0-beta1. Grafana Cloud instances have already been patched and an audit did not find any usage of this attack vector. Grafana Enterprise customers were provided with updated binaries under embargo. CVE-2021-41174 XSS vulnerability on unauthenticated pages Summary CVSS Score: 6.9 Medium CVSS:CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N/E:U/RL:O/RC:R/CR:L/MAV:N/MAC:H/MPR:N/MUI:R/MS:C/MC:N/MI:H/MA:L We received a security report to security@grafana.com on 2021-10-21 about a vulnerability in Grafana regarding the XSS vulnerability. It was later identified as affecting Grafana versions from 8.0.0-beta1 to 8.2.2. CVE-2021-41174 has been assigned to this vulnerability. Impact If an attacker is able to convince a victim to visit a URL referencing a vulnerable page, arbitrary JavaScript content may be executed within the context of the victim's…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3j9m-hcv9-rpj8
- Revision 1 · created ·
Published from osv record GHSA-3j9m-hcv9-rpj8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41174 Advisory: XSS vulnerability allowing arbitrary JavaScript execution IDs: CVE-2021-41174, GHSA-3j9m-hcv9-rpj8 Record: https://patchnext.com/advisories/cve-2021-41174 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @grafana/data 8.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @grafana/data: affected >= 8.0.0, < 8.2.3; fixed in 8.2.3 ## Suggested inspection (read-only) - `npm ls @grafana/data --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @grafana/data. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3j9m-hcv9-rpj8 (OSV record GHSA-3j9m-hcv9-rpj8 lists affected ranges: npm @grafana/data >=8.0.0 <8.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-3j9m-hcv9-rpj8 (GitHub-reviewed advisory GHSA-3j9m-hcv9-rpj8 lists affected ranges: npm @grafana/data >=8.0.0 <8.2.3) Commands are suggestions: review each one before running it.
Loading voting…