Skip to content

← Actionable
High, CVSS 8.2amended

HTML comments vulnerability allowing to execute JavaScript code

CVE-2021-41165GHSA-7h26-63m7-qhf2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor4 4.17.0; ckeditor/ckeditor 4.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L
EPSS
  • CVE-2021-41165: 1.57% estimated exploitation activity in the next 30 days; percentile 75.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected packages The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. Impact A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. Patches The problem has been recognized and patched. The fix will be available in version 4.17.0. For more information Email us at security@cksource.com if you have any questions or comments about this advisory. Acknowledgements The CKEditor 4 team would like to thank William Bowling (wbowling) for recognizing and reporting this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7h26-63m7-qhf2

  2. Revision 1 · created ·

    Published from osv record GHSA-7h26-63m7-qhf2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41165

Advisory: HTML comments vulnerability allowing to execute JavaScript code
IDs: CVE-2021-41165, GHSA-7h26-63m7-qhf2
Record: https://patchnext.com/advisories/cve-2021-41165 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckeditor4 4.17.0; ckeditor/ckeditor 4.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ckeditor4: affected < 4.17.0; fixed in 4.17.0
- Packagist ckeditor/ckeditor: affected < 4.17.0; fixed in 4.17.0

## Suggested inspection (read-only)
- `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Packagist ckeditor/ckeditor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckeditor4, ckeditor/ckeditor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7h26-63m7-qhf2 (OSV record GHSA-7h26-63m7-qhf2 lists affected ranges: npm ckeditor4 >=0 =0 <4.17.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7h26-63m7-qhf2 (GitHub-reviewed advisory GHSA-7h26-63m7-qhf2 lists affected ranges: npm ckeditor4 >=0 =0 <4.17.0)

Commands are suggestions: review each one before running it.

Loading voting…