Path Traversal in @backstage/plugin-scaffolder-backend
CVE-2021-41151GHSA-pvv8-8fx9-h673
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 0.15.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/plugin-scaffolder-backend
- Affected
- >= 0.9.4, < 0.15.9
- Fixed in
- 0.15.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pvv8-8fx9-h673 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0.9.4 <0.15.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pvv8-8fx9-h673 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0.9.4 <0.15.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2021-41151: 1.31% estimated exploitation activity in the next 30 days; percentile 70.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A malicious actor could read sensitive files from the environment where Scaffolder tasks are run. The attack is executed by crafting a custom Scaffolder template with a publish:github:pull-request action using a particular source path. When the template is executed the sensitive files would be included in the published pull request. This vulnerability is mitigated by the fact that an attacker would need access to create and register templates in the Backstage catalog, and that the attack is very visible given that the exfiltration happens via a pull request. Patches The vulnerability is patched in the 0.15.9 release of @backstage/plugin-scaffolder-backend. For more information If you have any questions or comments about this advisory: Open an issue in the Backstage repository Visit our chat, linked to in Backstage README
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pvv8-8fx9-h673
- Revision 1 · created ·
Published from osv record GHSA-pvv8-8fx9-h673
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41151 Advisory: Path Traversal in @backstage/plugin-scaffolder-backend IDs: CVE-2021-41151, GHSA-pvv8-8fx9-h673 Record: https://patchnext.com/advisories/cve-2021-41151 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 0.15.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/plugin-scaffolder-backend: affected >= 0.9.4, < 0.15.9; fixed in 0.15.9 ## Suggested inspection (read-only) - `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/plugin-scaffolder-backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pvv8-8fx9-h673 (OSV record GHSA-pvv8-8fx9-h673 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0.9.4 <0.15.9 (fixed)) - Verified: https://github.com/advisories/GHSA-pvv8-8fx9-h673 (GitHub-reviewed advisory GHSA-pvv8-8fx9-h673 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0.9.4 <0.15.9) Commands are suggestions: review each one before running it.
Loading voting…