Skip to content

← Actionable
High, CVSS 8.8amended

Arbitrary command execution on Windows via qutebrowserurl: URL handler

CVE-2021-41146GHSA-vw27-fwjf-5qxm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (qutebrowser 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-41146: 1.50% estimated exploitation activity in the next 30 days; percentile 74.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Starting with qutebrowser v1.7.0, the Windows installer for qutebrowser registers it as a handler for certain URL schemes. With some applications such as Outlook Desktop, opening a specially crafted URL can lead to argument injection, allowing execution of qutebrowser commands, which in turn allows arbitrary code execution via commands such as :spawn or :debug-pyeval. Only Windows installs where qutebrowser is registered as URL handler are affected. It does not have to be set as default browser for the exploit to work. Patches The issue has been fixed in qutebrowser v2.4.0 in commit 8f46ba3f6dc7b18375f7aa63c48a1fe461190430. The fix also adds additional hardening for potential similar issues on Linux (by adding the new --untrusted-args flag to the .desktop file), though no such vulnerabilities are known. Backported patches for older versions are available, but no further releases are planned: - v1.7.x: d1ceaab - v1.8.x: ca7155d - v1.9.x: 157d871 - v1.10.x: 94a6125 - v1.11.x:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vw27-fwjf-5qxm

  2. Revision 1 · created ·

    Published from osv record GHSA-vw27-fwjf-5qxm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41146

Advisory: Arbitrary command execution on Windows via qutebrowserurl: URL handler
IDs: CVE-2021-41146, GHSA-vw27-fwjf-5qxm
Record: https://patchnext.com/advisories/cve-2021-41146 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: qutebrowser 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI qutebrowser: affected >= 1.7.0, < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- `python -m pip show qutebrowser`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on qutebrowser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vw27-fwjf-5qxm (OSV record GHSA-vw27-fwjf-5qxm lists affected ranges: PyPI qutebrowser >=1.7.0 <2.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vw27-fwjf-5qxm (GitHub-reviewed advisory GHSA-vw27-fwjf-5qxm lists affected ranges: PyPI qutebrowser >=1.7.0 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…