Skip to content

← Actionable
High, CVSS 8.1

Pterodactyl Panel vulnerable to authentication bypass due to improper user-provided security token verification

CVE-2021-41129GHSA-5vfx-8w6m-h3v4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-41129: 1.75% estimated exploitation activity in the next 30 days; percentile 77.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A malicious user can modify the contents of a confirmationtoken input during the two-factor authentication process to reference a cache value not associated with the login attempt. In rare cases this can allow a malicious actor to authenticate as a random user in the Panel. The malicious user must target an account with two-factor authentication enabled, and then must provide a correct two-factor authentication token before being authenticated as that user. Impact Due to a validation flaw in the logic handling user authentication during the two-factor authentication process a malicious user can trick the system into loading credentials for an arbitrary user by modifying the token sent to the server. This authentication flaw is present in the LoginCheckpointController@invoke method which handles two-factor authentication for a user. This controller looks for a request input parameter called confirmationtoken which is expected to be a 64 character random alpha-numeric string that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5vfx-8w6m-h3v4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41129

Advisory: Pterodactyl Panel vulnerable to authentication bypass due to improper user-provided security token verification
IDs: CVE-2021-41129, GHSA-5vfx-8w6m-h3v4
Record: https://patchnext.com/advisories/cve-2021-41129 (revision 1, source checked 26 Oct 2026, 13:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pterodactyl/panel: affected >= 1.0.0, < 1.6.2; fixed in 1.6.2

## Suggested inspection (read-only)
- Packagist pterodactyl/panel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pterodactyl/panel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5vfx-8w6m-h3v4 (GitHub-reviewed advisory GHSA-5vfx-8w6m-h3v4 lists affected ranges: Packagist pterodactyl/panel >=1.0.0 <1.6.2)

Commands are suggestions: review each one before running it.

Loading voting…