Skip to content

← Actionable
High, CVSS 7.2

Deleted Admin Can Sign In to Admin Interface

CVE-2021-41126GHSA-6gjf-7w99-j7x7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 2.1.12; october/october 2.1.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-41126: 1.09% estimated exploitation activity in the next 30 days; percentile 65.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Assuming an administrator once had previous access to the admin interface, they may still be able to sign in to the backend using October CMS v2.0. Patches The issue has been patched in v2.1.12 Workarounds - Reset the password of the deleted accounts to prevent them from signing in. - Please contact hello@octobercms.com for code change instructions if you are unable to upgrade. References Credits to: • Daniel Bidala For more information If you have any questions or comments about this advisory: Email us at hello@octobercms.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6gjf-7w99-j7x7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41126

Advisory: Deleted Admin Can Sign In to Admin Interface
IDs: CVE-2021-41126, GHSA-6gjf-7w99-j7x7
Record: https://patchnext.com/advisories/cve-2021-41126 (revision 1, source checked 26 Oct 2026, 13:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 2.1.12; october/october 2.1.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected >= 2.1.0, < 2.1.12; fixed in 2.1.12
- Packagist october/october: affected >= 2.1.0, < 2.1.12; fixed in 2.1.12

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.
- Packagist october/october: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system, october/october.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6gjf-7w99-j7x7 (GitHub-reviewed advisory GHSA-6gjf-7w99-j7x7 lists affected ranges: Packagist october/october >=2.1.0 =2.1.0 <2.1.12)

Commands are suggestions: review each one before running it.

Loading voting…